Intellect Board Pro
Система управления форумами
Объявление

30 ноября 2015 года выпущена окончательная версия Intellect Board 3.00! Перейти к скачиванию
Также доступен конвертор данных для IntB 2.22

Для получения новостей о новых версиях подписывайтесь на наши страницы ВКонтакте и в Twitter.

Привет, гость!

HURL TexCMS

Не могу настроить HURL на Debian 8.10

Настройки отображения темы Показывать по сообщений с сортировкой .
Выводить , отправленные .
Одна страница
Распечатать
noszone
Новичок
Всего сообщений: 5
Зарегистрирован: 11 апр 2018, 15:32
Рейтинг пользователя: 0

0 +
11 апреля 2018, 15:39#1
Приветствую, проблема в следующем,

Не могу добиться того, чтобы HURL заработали. Выводит 404 ошибку и всё.

Что я пробовал. Танцы с apache 2.4., htaacess. Уже не знаю куда копать. Точно знаю, что htaccess подхватывается (бросал мусор в него и получал 500 ошибку), а всё равно мне любая страница кроме главной отдаёт не найдено 404.

Создал на денвере - работает (убрал нижнюю часть htaccess где уже не роутинг, а так тоже давало 500). Логи апача смотрел, но там кроме 404 ничего нету.

Куда копать, может кто-нибудь пожалуйста подсказать?

noszone
Новичок
Всего сообщений: 5
Зарегистрирован: 11 апр 2018, 15:32
Рейтинг пользователя: 0

0 +
11 апреля 2018, 15:40#2
Вот что выводит:

Not Found

The requested URL /555/ was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.4.10 (Debian) Server at ********* Port 443

Не может ли это быть связанным с тем что сайт на https?

4X_Pro
Основатель проекта
Всего сообщений: 214
Зарегистрирован: 22 сен 2014, 18:56
Откуда: Москва, Перово
Рейтинг пользователя: 4

0 +
11 апреля 2018, 15:56. Редактировалось 1 раз, последний — 11 апреля 2018, 15:56#3
С https — вряд ли.
Советую проверить следующее:
  1. Включен ли вообще mod_rewrite (на VDSах при установке Apache самостоятельно он изначально выключен, да и на некоторых хостингах тоже).
  2. Директиву RewriteBase, часто бывают проблемы, если она не прописана.
И ещё заглянуть в лог ошибок, возможно, он что-то прояснит.

Критикуя — предлагай, предлагая — обосновывай!
4xpro.ru — мой личный сайт-мультиблог на Intellect Board.

noszone
Новичок
Всего сообщений: 5
Зарегистрирован: 11 апр 2018, 15:32
Рейтинг пользователя: 0

0 +
11 апреля 2018, 16:03. Редактировалось 1 раз, последний — 11 апреля 2018, 16:07#4
включен mod_rewrite и через a2enmod и через php info проверял - нифига. На этом же впс другой сайт крутится у него пашет всё.
Rewrite base стоит дефолтный - /

В логах смотрел access & error.log ничего такого не увидел там. Пишет 404 и потом разные цифры даёт. Например:

"GET /555/ HTTP/1.1" 404 822 "https://**/" "Mozilla/5.0 (Windows NT 6.1; rv:59.0) Gecko/20100101 Firefox/59.0"
"GET /555/ HTTP/1.1" 404 684 "https://**/" "Mozilla/5.0 (Windows NT 6.1; rv:59.0) Gecko/20100101 Firefox/59.0"

4X_Pro
Основатель проекта
Всего сообщений: 214
Зарегистрирован: 22 сен 2014, 18:56
Откуда: Москва, Перово
Рейтинг пользователя: 4

0 +
11 апреля 2018, 20:59. Редактировалось 1 раз, последний — 11 апреля 2018, 21:01#5
А если попытаться явно прописать
RewriteRule ^555 index.php [L]
сразу после RewriteBase, это поможет или нет?
На всякий случай нужно проверить, что нет каталога с именем 555 или файлов 555.* (например, 555.jpg) в корне.
Также попробуйте закомментировать строки <IfModule mod_rewrite.c> и </IfModule>.

Если совсем ничего не поможет, то нужно включить логи mod_rewrite директивой
LogLevel alert rewrite:trace3
В этом случае в лог будет идти информация о том, какие редиректы делаются модулем log_rewrite.

Критикуя — предлагай, предлагая — обосновывай!
4xpro.ru — мой личный сайт-мультиблог на Intellect Board.

noszone
Новичок
Всего сообщений: 5
Зарегистрирован: 11 апр 2018, 15:32
Рейтинг пользователя: 0

0 +
12 апреля 2018, 07:34#6
Если явно прописать, то да работает. Кажется нашёл в чем проблема. У меня директива осталась незамеченной со вчерашнего дня - RewriteCond %{SERVER_PORT} !^443$. Это я пробовал и забыл убрать. Сейчас работает. Но главная проблема получается была в конфигах апача+виртуалхост. А именно с Allowoverride None. А может еще что-то где-то. Всё же перерыли. В общем спасибо.

Пользуясь случаем, хотел спросить. После перехода на урл 555, адрес в шапке сайта главной страницы меняется на 555. То есть, не получается на главную перейти. Я просто свой шаблон поставил, но вроде ничего такого не убирал. Просто если особенностей нет, я тупо явно укажу.

4X_Pro
Основатель проекта
Всего сообщений: 214
Зарегистрирован: 22 сен 2014, 18:56
Откуда: Москва, Перово
Рейтинг пользователя: 4

0 +
13 апреля 2018, 00:02#7
noszone написал(а):
Просто если особенностей нет, я тупо явно укажу.

Да, каких-либо особенностей нет. Можно указать либо просто / в качестве пути, либо ##url[/]#.

Критикуя — предлагай, предлагая — обосновывай!
4xpro.ru — мой личный сайт-мультиблог на Intellect Board.

Одна страница
Распечатать

У вас нет прав для отправки сообщений в эту тему.

0: Контрольная точка "Конец инициализации". Время выполнения: 0.006. Запросов: 8, время запроса: 0.001 (19.54)%. Памяти использовано: 513608 байтов

0: Контрольная точка "Фиксация действия пользователя выполнена". Время выполнения: 0.007. Запросов: 10, время запроса: 0.002 (22.32)%. Памяти использовано: 513936 байтов

0: Контрольная точка "Основное действие выполнено". Время выполнения: 0.011. Запросов: 17, время запроса: 0.003 (25.17)%. Памяти использовано: 685616 байтов

0: Контрольная точка "Вспомогательные действия выполнены". Время выполнения: 0.011. Запросов: 19, время запроса: 0.003 (25.53)%. Памяти использовано: 693224 байтов

0: Контрольная точка "После срабатывания шаблонизатора.". Время выполнения: 0.015. Памяти использовано: 980832 байтов