Intellect Board Pro
Расширяемая система управления форумами с открытым исходным кодом
Объявление
Выпущена версия 3.02 с двумя новыми типами разделов: блог и микроблог.
Перейти к скачиванию
Привет, гость!

Беда с установкой

Настройки отображения темы Показывать по сообщений с сортировкой .
Выводить , отправленные .
Страницы:
Распечатать
dim
Новичок
Всего сообщений: 3
Зарегистрирован: 12 июл 2015, 17:44
Рейтинг пользователя: 0

0
12 июля 2015, 17:52#1
    Давно пользовался иб22 - отличные были времена. И задумка хорошая.
    Тут что-то даже установить не получается. Ни локально на битрикс-машину, ни на хостинг.

    Первая страница говорит - все прекрасно
    Проверяем необходимые для работы Intellect Board функции:
    Поддержка вызова произвольной функции (функция call_user_func): Ok
    Поддержка буферизации вывода (функция ob_start): Ok
    Поддержка сессий (функция session_start): Ok
    Поддержка регулярных выражений (функция preg_match): Ok
    Поддержка хеша MD5 (функция md5): Ok
    Проверяем функции для дополнительных опций Intellect Board
    Сжатие страниц с помощью GZIP (функция gz_handler): Ok
    Работа с изображениями с помощью библиотеки GD (функция gd_info): Ok
    Отправка почты средствами PHP (функция mail): Ok
    Работа со строками Unicode (функция mb_strlen): Ok
    Расширения для работы с СУБД
    MySQLi: Ok
    MySQL: Ok
    Права доступа и место на диске
    Каталог etc/: доступен для записи
    Каталог logs/: доступен для записи
    Каталог tmp/: доступен для записи
    Свободно на диске: 2635 Мб
    Все необходимые условия для установки выполнены!
    Выберите желаемое действие:
    Провести начальную настройку Intellect Board с нуля

    А вот когда доходим до шага 4:
    Проверка подключения к базе данных
    Прорверка префикса таблиц: Ok
    Подключение общего класса баз данных (файл db/database.php): Ok
    Подключение драйвера mysqli (файл db/mysqli): Ok

    Warning: mysqli_connect() [function.mysqli-connect]: [2002] ������� ���������� ���������� ���� �����������, �.�. �� ������� (trying to connect via tcp://localhost:3306) in C:\Bitrix\www\xn--80aae7atxus.xn--p1ai\db\mysqli.php on line 28

    Warning: mysqli_connect() [function.mysqli-connect]: (HY000/2002): ������� ���������� ���������� ���� �����������, �.�. �� ������� ���������� �� ��������� ����� �� ������� ������ ������, ��� ���� ��������� ��� ������������� ���������� ��-�� ��������� ������� ��� ������������� ����������. in C:\Bitrix\www\xn--80aae7atxus.xn--p1ai\db\mysqli.php on line 28

    Warning: mysqli_query() expects parameter 1 to be mysqli, boolean given in C:\Bitrix\www\xn--80aae7atxus.xn--p1ai\db\mysqli.php on line 29

    Warning: mysqli_error() expects parameter 1 to be mysqli, boolean given in C:\Bitrix\www\xn--80aae7atxus.xn--p1ai\db\mysqli.php on line 77

    Fatal error: Ошибка подключения к базе данных! in C:\Bitrix\www\xn--80aae7atxus.xn--p1ai\db\mysqli.php on line 30

    4X_Pro
    Основатель проекта
    Всего сообщений: 240
    Зарегистрирован: 22 сен 2014, 18:56
    Откуда: Москва, Перово
    Рейтинг пользователя: 6

    0
    12 июля 2015, 18:14#2
      Попробуйте выставить кодировку в броузере так, чтобы сообщение об ошибке стало читаемым (скорее всего, надо поставить windows-1251), тогда будет проще понять, что же там происходит.
      Также попробуйте исправить строку 28 в файле db/mysqli.php на такую:
      $this->link=mysqli_connect($host,$params['DB_username'],$params['DB_password'],$params['DB_name']);
      Судя по всему, функция mysqli_connect даже пустую строку воспринимает как указание коннектиться через socket, а не по TCP/IP, отсюда и ошибка вылезает.

      Критикуя — предлагай, предлагая — обосновывай!
      4xpro.ru — мой личный сайт-мультиблог на Intellect Board.

      dim
      Новичок
      Всего сообщений: 3
      Зарегистрирован: 12 июл 2015, 17:44
      Рейтинг пользователя: 0

      0
      13 июля 2015, 06:46#3
        Warning: mysqli_connect() [function.mysqli-connect]: [2002] Попытка установить соединение была безуспешной, т.к. от другого (trying to connect via tcp://localhost:3306) in C:\Bitrix\www\xn--80aae7atxus.xn--p1ai\db\mysqli.php on line 28

        Warning: mysqli_connect() [function.mysqli-connect]: (HY000/2002): Попытка установить соединение была безуспешной, т.к. от другого компьютера за требуемое время не получен нужный отклик, или было разорвано уже установленное соединение из-за неверного отклика уже подключенного компьютера. in C:\Bitrix\www\xn--80aae7atxus.xn--p1ai\db\mysqli.php on line 28


        ммм... увидел. лезет на порт 3306, хотя у меня 31006 прописан. где поправить?

        4X_Pro
        Основатель проекта
        Всего сообщений: 240
        Зарегистрирован: 22 сен 2014, 18:56
        Откуда: Москва, Перово
        Рейтинг пользователя: 6

        0
        13 июля 2015, 15:14. Редактировалось 1 раз, последний — 13 июля 2015, 15:14#4
          Нашел причину. В install.php нужно строку (у меня это строка 281)
          echo '<div><label><span class="fd">Хост и порт:</span> <input type="text" name="params[DB_host]" required="required" value="'.htmlspecialchars($db_host).'"></label>:<input type="text" size="5" name="DB_port" value="'.$db_port.'""> (оставьте пустым, чтобы использовать порт по умолчанию)</div>';
          заменить на
          echo '<div><label><span class="fd">Хост и порт:</span> <input type="text" name="params[DB_host]" required="required" value="'.htmlspecialchars($db_host).'"></label>:<input type="text" size="5" name="params[DB_port]" value="'.$db_port.'""> (оставьте пустым, чтобы использовать порт по умолчанию)</div>';
          Т.е. свойство name у input, в котором порт задается, было неправильно прописано, поэтому брался порт по умолчанию.

          Критикуя — предлагай, предлагая — обосновывай!
          4xpro.ru — мой личный сайт-мультиблог на Intellect Board.

          dim
          Новичок
          Всего сообщений: 3
          Зарегистрирован: 12 июл 2015, 17:44
          Рейтинг пользователя: 0

          0
          13 июля 2015, 17:46#5
            отлично! завелось

            ПнБ
            Начинающий
            Всего сообщений: 98
            Зарегистрирован: 5 мая 2015, 11:37
            Рейтинг пользователя: 0

            0
            28 августа 2016, 16:20#6
              Пробую установить "тройку" на локаль. У меня уже пальцы стёрлись. 4ХPro, на хрена указывать, что версия PHP не ниже 5.3, если в файле install.php содержится функция вызова call_user_func, которая как раз таки начиная с версии 5.3.0-НЕ ПОДДЕРЖИВАЕТСЯ? Где мне в твоём ООП искать ей недостающий параметр? И это при том, что я поменял в том же инсталл патчи, иначе вываливался десяток ошибок
              $pos=strrpos($_SERVER['DOCUMENT_ROOT'],'www/'); // последний www в пути будет каталогом www в дистрибутиве IntB $this->sitepath=($pos) ? substr($_SERVER['DOCUMENT_ROOT'],0,$pos) : dirname($_SERVER['DOCUMENT_ROOT']);
              потому что скрипт не находит пути. А версию PHP инсталятор бракует с первого шага.
              Ошибка в общем, такая:
              Warning: call_user_func() expects parameter 1 to be a valid callback, class 'Application' does not have a method '!' in D:\OpenServer(стр 124

              Всё, что мне известно о PHP-меня научил 4X_Pro
              Опрос пользователей о деятельности _1_ http://intbpro.ru/flood/119/

              ПнБ
              Начинающий
              Всего сообщений: 98
              Зарегистрирован: 5 мая 2015, 11:37
              Рейтинг пользователя: 0

              0
              28 августа 2016, 16:36#7
                И я сразу скажу-все правки из этой темы я делал.

                Всё, что мне известно о PHP-меня научил 4X_Pro
                Опрос пользователей о деятельности _1_ http://intbpro.ru/flood/119/

                ПнБ
                Начинающий
                Всего сообщений: 98
                Зарегистрирован: 5 мая 2015, 11:37
                Рейтинг пользователя: 0

                0
                31 августа 2016, 11:05#8
                  Установку произвёл, но с устаревшей функцией надо что-то делать.

                  Всё, что мне известно о PHP-меня научил 4X_Pro
                  Опрос пользователей о деятельности _1_ http://intbpro.ru/flood/119/

                  4X_Pro
                  Основатель проекта
                  Всего сообщений: 240
                  Зарегистрирован: 22 сен 2014, 18:56
                  Откуда: Москва, Перово
                  Рейтинг пользователя: 6

                  0
                  31 августа 2016, 18:46#9
                    С чего это она вдруг не поддерживается? call_user_func благополучно перешла в PHP 7, в документации ни слова об устаревании нет.
                    В PHP 5.3 что-то меняли в формате ее вызова, но я вроде новый вариант и использую, где в качестве первого аргумента передается массив из двух элементов: сначала объект, потом имя метода.
                    ПнБнаписал(а):
                    Warning: call_user_func() expects parameter 1 to be a valid callback, class 'Application' does not have a method '!' in D:\OpenServer

                    Строка 124 выглядит следующим образом:
                    <?php call_user_func(array($this,'action_step'.$this->step)); ?>
                    И ошибка там происходит потому, что вместо 'action_step'.$this->step каким-то образом там оказался знак вопроса. Видимо, ты что-то наредактировал...

                    Критикуя — предлагай, предлагая — обосновывай!
                    4xpro.ru — мой личный сайт-мультиблог на Intellect Board.

                    4X_Pro
                    Основатель проекта
                    Всего сообщений: 240
                    Зарегистрирован: 22 сен 2014, 18:56
                    Откуда: Москва, Перово
                    Рейтинг пользователя: 6

                    0
                    31 августа 2016, 18:46. Редактировалось 2 раза, последний — 31 августа 2016, 18:47#10
                      С чего это она вдруг не поддерживается? call_user_func благополучно перешла даже в PHP 7 (вчера на локали специально поставил, чтобы проверить), в документации ни слова об устаревании нет.
                      В PHP 5.3 что-то меняли в формате ее вызова, но я вроде новый вариант и использую, где в качестве первого аргумента передается массив из двух элементов: сначала объект, потом имя метода.
                      ПнБнаписал(а):
                      Warning: call_user_func() expects parameter 1 to be a valid callback, class 'Application' does not have a method '!' in D:\OpenServer

                      Строка 124 выглядит следующим образом:
                      <?php call_user_func(array($this,'action_step'.$this->step)); ?>
                      И ошибка там происходит потому, что вместо 'action_step'.$this->step в качестве имени вызываемого метода каким-то образом оказался знак вопроса. Видимо, ты что-то наредактировал, т.к. при нормальной работе PHP такое получить нельзя — строка 'action_step' никуда не денется.

                      Критикуя — предлагай, предлагая — обосновывай!
                      4xpro.ru — мой личный сайт-мультиблог на Intellect Board.

                      Страницы:
                      Распечатать

                      У вас нет прав для отправки сообщений в эту тему.

                      0: Контрольная точка "Конец инициализации". Время выполнения: 0.002. Запросов: 8, время запроса: 0.001 (51.18)%. Памяти использовано: 519848 байтов

                      0: Контрольная точка "Фиксация действия пользователя выполнена". Время выполнения: 0.002. Запросов: 10, время запроса: 0.001 (52.93)%. Памяти использовано: 520176 байтов

                      0: Контрольная точка "Основное действие выполнено". Время выполнения: 0.006. Запросов: 17, время запроса: 0.003 (40.43)%. Памяти использовано: 738000 байтов

                      0: Контрольная точка "Вспомогательные действия выполнены". Время выполнения: 0.007. Запросов: 21, время запроса: 0.003 (42.72)%. Памяти использовано: 753640 байтов

                      0: Контрольная точка "После срабатывания шаблонизатора.". Время выполнения: 0.013. Памяти использовано: 1051664 байтов